Para usar Chatrandom, debes tener instalada la última versión de Flash Player installed.

Descargar e instalar Flash Player